Drobo works but file system corrupt

Yuck. DroboPro is nice. Get a new Drobo by fedex and I inserted all the drives, but a bunch of problems. First I upgraded to Lion and iSCSI and Drobo’s on Lion don’t work. Others on Apple’s community and here have reported this. Seems like a problem with something called the iSCSI initiator that comes with the Drobo Dashboard. The reports also say it doesn’t work with Firewire either so beware…

However I can say that I have seen reports saying that the free GlobalSAN iSCSI client for Mac currently has problems with Lion, whereas the commerical one from ATTO Technology is supposed to work fine with Lion.

I have the exact same problem, but with a DroboPro connected via iSCSI. I found that uninstalling Dashboard and going back to a very early version (1.7.3 in my case) does help a lot, but does not entirely fix the problem. With Dashboard 2.0.x the Drobo unit is basically unusable with constant disconnects/freezes. With Dahsboard 1.7.3 this only happens once every couple of days.

I am very sorry for the inconvenience. Thank you for contacting Drobo Technical Support. Unfortunately the update to Lion has broken compatibility with iSCSI devices. Until we can get the Dashboard updated, or GlobalSan comes out with a Lion compatible iSCSI connection, I recommend switching to Firewire 800.

Yes – FW800 seems to still freeze but not every minute like ISCSI. I have had a couple of hang-ups in the last day or so. I believe I am going to switch to USB to see if that even works and will be supplying the diag and open a new ticket for FW800.

Flipped to Firewire and when you try to boot, the iMac hangs on the Drobo. Seems like it thinks it is a drive.

Then in the course of changing around, my main partition gets corrupted and won’t mount. There data is still there.

Tried to run Disk Utility but it says invalide node structure.

So got out a copy of DiskWarrior. It hangs the Firewire on Lion. Darn it. Tried it on a clean MacBook Pro also running Firewire. Get these strange console messages saying things the Firewire doesn’t work.

Right now trying it with a MacBook with Snow Leopard and trying it now on USB. See what happens. At least no errors reported. Hope I can get it back! As I read the support pages Drobo itself recommends going to USB and trying DiskWarrior or TechTools from Apple. After about four hours of grinding, DiskWarrior actually worked and restored it!

The big lesson here is that even with a Drobo and RAID 5 effective, you are vulnerable to more than two hard disks crashing. For complete reliability, you should backup to the internet (Crashplan!), have a pair of RAID boxes that you sync so that if there is a file system corruption it won’t infect both or if there is a hardware problem in the RAID array itself.

Finally run with RAID 5 so that you get two disk redundency and get a UPS for both. Seems like overkill for home until you realize.